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What is data analysis?

«Data analysis involves sorting through massive amounts of 

unstructured information and deriving key insights from it, which are 

enormously valuable for decision-making».

An overview of how data analysis is done:

Define the question or goal behind the analysis: what are you trying to

discover?

Collect the right data to help answer this question.

Perform data cleaning/data wrangling to improve data quality and prepare it

for analysis and interpretation.

Manipulate data using Spreadsheets (such as Excel).

Analyze and interpret the data using statistical tools (i.e. finding correlations,

trends, outliers, etc.).

Present this data in meaningful ways: graphs, visualizations, charts, tables,

etc.



We use Excel for:

Entering, storing, organizing, analyzing different kinds of data.

Representing data in a variety of ways, with visually interesting charts and

graphs (e.g. in bar graphs, line graphs, and scatterplots).

Performing calculations with mathematical and statistical functions.

Introduction to Excel (1)

«Excel is one of the most popular spreadsheet applications».

«A Spreadsheet is a grid of rows and columns in which you enter text, 

numbers, as wells as the results of calculations».



Introduction to Excel (2)

Advantages of Excel (and spreadsheets in general):

The space allowed to the user by the “spreadsheet” is unlimited.

Information is organized and is easy to access.

Information is easy to edit if a mistake has been made by retyping or using

“undo”.

Data can be quickly analyzed.

Data can be easily sorted and filtered.

Calculations are completed automatically.

Calculations are correct.

Reports can be made more visual by using charts and graphs.



Opening Microsoft Excel (1)

To open Excel and create a Workbook:

Start menu > All Programs > Microsoft Office > Excel (or “Search” Excel).

File > New > Blank Workbook.

Workbook

The file (with 

extension .xls or 

.xlsx) used to 

store various 

Excel sheets, 

which are called 

worksheets.



Opening Microsoft Excel (2)

To open Excel and create a Workbook:

Start menu > All Programs > Microsoft Office > Excel (or “Search” Excel).

File > New > Blank Workbook.

Workbook

The file (with 

extension .xls or 

.xlsx) used to 

store various 

Excel sheets, 

which are called 

worksheets.



Opening Microsoft Excel (3)



Saving a document

To save an Excel file (Workbook):

File > Save as.

In a dialog box, you can specify: 1) the new file’s name, 2) location of where

you want it saved, and 3) format of the document.

Press “Save” button in the dialog box.

Don’t forget to periodically save your work as insurance against a computer

freeze or a power outage (click the “save” button).

Saving dialog box
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1. The area outlined in yellow is called the “Title bar” - It displays the 

name of the open program (in this case Microsoft Excel) and the 

name of the current file (workbook name).

2. The area outlined in blue is the work area (the active worksheet).

3. The area outlined in green includes the sheet tabs - Here we can 

create worksheets (press “+”) and manage them (choose, change 

name, delete, move).
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About worksheets

We can create new worksheets by pressing the “+” button.

The worksheet displayed in the work area is the active worksheet.

We can delete a worksheet, rename it (double-click and type a new name) or

move it (hold, drag & release mouse).

Also, we can do the previous actions from the pop-up window (right click).

Pop-up
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4. The area outlined in yellow is called “Quick Access Toolbar” - It

contains the most commonly used commands (Save, Undo, Redo).

5. The area outlined in blue is called “Ribbon” - It depicts all the 

features in easy to understand form (expanded menu) - “Ribbon”

is broken into “Tabs” (Home, Insert, Data…) & “Tabs” into groups.

6. The area outlined in green is where any calculations or formulas

we write will appear.
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The “Home Tab” Groups contain the commands 

most commonly associated with the formatting 

and editing of cells and their contents.

Number Styles Cells Editing

Clipboard Font Alignment



The “Insert Tab” Groups contain the commands 

most commonly associated with adding 

something to the document.

Charts Tours Sparklines

Filters

Tables Illustrations Add-ins

Links Text & Symbols



The “Page Layout Tab” Groups contain the 

commands most commonly associated with 

settings that affect the entire page or worksheet.

Sheet Options Arrange

Themes Page Setup Scale to Fit



The “Formulas Tab” Groups contain the 

commands most commonly associated with 

Excel’s formulas and functions.

Calculation

Function

Library

Defined

Names Formula

Auditing



The “Data Tab” Groups contain the commands 

most commonly associated with data from 

external sources, and evaluating/arranging data.

Data Tools Forecast Outline

Get & Transform Connections Sort & Filter



The “Review Tab” Groups contain the 

commands most commonly associated with text 

portions of a spreadsheet and sharing changes.

Language Comments Protect

Proofing Accessibility Insights



The “View Tab” Groups contain the commands 

most commonly associated with the variety of 

ways you can “look at” a worksheet/workbook.

Window Macros

Workbook 

views
Show Zoom



Excel organize information (text and 

numbers) by rows and columns

• Rows are represented by numbers along the side of the sheet

• Columns are represented by letters across the top of the sheet

• A cell is the intersection of a row and a column (unique name)

ROW

COLUMN

Cell B9



The Excel Interface



Data entry – Active cell

To enter information into a cell: Click on a cell, and type in the data

(numbers or text) and press Enter.

The cell in the worksheet in which you can type data is called the active cell.

A border will appear around the active cell indicating that it is a selected cell.

The contents of the active cell always appear in the Formula Bar.

We can change the active cell either by moving the pointer or by using keys.

Data Entry Keyboard navigation

Active Cell



Flash Fill (1)

Excel Flash Fill is a special tool that analyzes the information you are

entering and automatically fills data when it identifies a pattern.

Flash Fill easily copes with dozens of different tasks, such as:

- splitting and combining text strings,

- cleaning data and correcting inconsistencies,

- formatting text and numbers,

- converting dates to the desired format.

The Flash Fill tool resides on the “Data Tab”, in the “Data Tools” group.

You can run Flash Fill with this key combination: Ctrl + E.



Flash Fill (2)

Usually Flash Fill starts automatically, and you only need to provide a

pattern. Here's how:

1. Insert a new column adjacent to the column with your source data.

2. In the first cell of a newly added column, type the desired value.

3. Start typing in the next cell, and if Excel senses a pattern, it will show a

preview of data to be auto-filled in the below cells.

4. Press the Enter key to accept the preview.



Changing data in a cell – Cut, Copy, and Paste

You can edit, replace, or clear data.

You may change an entry within a cell two different ways:

- Click the cell one time and begin typing. The new information will replace any

information that was previously entered.

- Double click the cell and a cursor will appear inside. This allows you to edit

certain pieces of information within the cells instead of replacing all of the data

at once.

You can use the Cut, Copy and Paste features of Excel to change the data

within your worksheet or to move data from other worksheet into new

worksheets.

To Cut or Copy & Paste:

- Highlight the data or text by selecting the cells that they are held within.

- Go to Edit > Copy (Command-C) or Edit > Cut (Command-X).

- Click the location where the information should be placed.

- Go to Edit > Paste (Command-V).



Finding & Replacing data (1) 

You can easily search the worksheet using the “Find” feature, which also

allows you to modify content using the “Replace” feature.

From the “Home Tab”, click the “Find & Select” command, then select

“Find” (or “Replace”) (also by pressing “Command-F”).



Finding & Replacing data (2) 

You can easily search the worksheet using the “Find” feature, which also

allows you to modify content using the “Replace” feature.

From the “Home Tab”, click the “Find & Select” command, then select

“Find” (or “Replace”) (also by pressing “Command-F”).



Selecting group of cells

A group of selected cells is called a range - The range is identified by its

range reference, e.g. a) B3:F3, b) A3:C5.

In an adjacent range, all cells touch each other and form a rectangle

- To select an adjacent range, click the cell in a corner of the range, drag the

pointer to the cell in the opposite corner of the range, and release the mouse

button.

A nonadjacent range has two or more adjacent ranges and selected cells

- To select a nonadjacent range, select the first adjacent range or cell, press

the Ctrl key as you select the other cells or ranges you want to include, and

then release the Ctrl key and the mouse button.

B3:F3

A3:C5



Using the fill handle (1)

You can use the “fill handle” to quickly copy and paste content to adjacent

cells in the same row or column.

Select the cell(s) containing the content you wish to use - The “fill handle”

will appear as a small square in the bottom-right corner of the selected cell(s).

Click & drag the “fill handle” until all of the cells you wish to fill are selected.



Using the fill handle (2)

You can use the “fill handle” to quickly copy and paste content to adjacent

cells in the same row or column.

Select the cell(s) containing the content you wish to use - The “fill handle”

will appear as a small square in the bottom-right corner of the selected cell(s).

Click & drag the “fill handle” until all of the cells you wish to fill are selected.



Rotating rows/columns (1)

When you need to rotate columns and rows, you transpose them in Excel.

Select & Copy the cell(s) containing the content you wish to use - On the

“Home Tab”, click the arrow under the Paste button.

Click Paste Special, and then click the checkbox for Transpose - Press OK.



Rotating rows/columns (2)

When you need to rotate columns and rows, you transpose them in Excel.

Select & Copy the cell(s) containing the content you wish to use - On the

“Home Tab”, click the arrow under the Paste button.

Click Paste Special, and then click the checkbox for Transpose - Press OK.



Formatting cells (1)

There are various different options that can be changed to format the cells

differently - When changing the format within cells you must select the cells

that you wish to format.

To get to the “Format Cells” dialog box select the cells you wish to change

then press right click and go to Format > Cells - A box will appear on the

screen with 6 different tab options (4 of these are presented below):

 Number: Allows you to change the measurement in which your data is used

(if your data is concerned with money the number that you would use is

currency).

 Alignment: This allows you to change the horizontal and vertical alignment

of your text within each cell - You can also change the orientation of the text

within the cells and the control of the text within the cells as well.

 Font: Gives the option to change the size, style, color, and effects.

 Border: Gives the option to change the design of the border around or

through the cells.



Formatting cells (2)



Formatting cells (3)



Formatting cells (4)



Formatting cells (5)



Formatting cells (6)



Formatting cells (7)

x2

x2



Formatting cells (8)



Formatting cells (9)

Font Style - Size
Bold – Italics –

Underline

Add boarders

To change 

horizontal & 

vertical alignment

To add fill & font 

color



Formatting cells (10)



Formatting/Adding rows & columns

When formatting rows and columns you can: (1) change the height (or

width), (2) hide (or un-hide) information within a row or column, or (3)

delete the row/column.

When adding a row or column you are inserting a blank row or column next

to your already entered data - To insert multiple at once, select the number

of rows/columns you would like to insert.

1

2

3

1

2

3

Column

Row

Hide

Information



Freezing rows & columns (1)

You may want to see certain rows or columns all the time in your worksheet,

especially header cells.

By freezing rows or columns in place, you'll be able to scroll through your

content while continuing to view the frozen cells.

Click the “View Tab” and go to “Freeze Panes” - Choose “Freeze Top Row”

from the drop-down menu.

Choose “Unfreeze Panes” to unfreeze rows.



Freezing rows & columns (2)

FREEZE

NO 

FREEZE



Conditional Formatting (1)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From the “Home Tab”, click the “Conditional Formatting” command.



Conditional Formatting (2)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From the “Home Tab”, click the “Conditional Formatting” command.



Conditional Formatting (3)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From the “Home Tab”, click the “Conditional Formatting” command.



Conditional Formatting (4)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From the “Home Tab”, click the “Conditional Formatting” command.



Sorting/Filtering Data (1)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select the “Home Tab”, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (2)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select the “Home Tab”, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (3)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select the “Home Tab”, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (4)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select the “Home Tab”, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (5)

Filters can be used to narrow down the data in your worksheet, allowing you

to view only the information you need.

In order for filtering to work correctly, your worksheet should include a header

row, which is used to identify the name of each column.

Select the “Home Tab”, then click Sort & Filter > Filter - A drop-down arrow

will appear in the header cell for each column - Click the drop-down arrow for

the column you wish to filter.



Working with charts (1)

Charts are an important part to being able to create a visual for spreadsheet

data - Showing data in a chart can make it clearer, more interesting and

easier to read.

Once the data are entered, the cells that are going to be used for the chart

need to be highlighted so that the software knows what to include.

Excel provides a variety of chart types that you can choose from when you

create a chart.

 Column charts / Bar charts use vertical / horizontal bars to represent data. They

can work with many different types of data, but they’re usually used for comparing

information.

 Pie charts make it easy to compare proportions. Each value is shown as a slice of

the pie, so it's easy to see which values make up the percentage of a whole.

 Line charts are ideal for showing trends. The data points are connected with lines,

making it easy to see whether values are increasing or decreasing over time.

 Scatterplots are an excellent way to visually display the relationship (correlation)

between two variables.



Working with charts (2)



Working with charts (3)

Charts:

• Charts present information in the form

of graphs, diagrams, maps or tables.

• Charts are a large group of methods

for presenting information.

Graphs:

• Graphs show the mathematical

relationship between sets of data.

• Graphs are one type of chart, but not

the only type of chart.

«In other words, all graphs are charts, but not all charts are graphs».



Working with charts (4)

Select the cells you want to chart, including the column titles and row labels.

From the “Insert Tab”, click the desired Chart command.

Choose the desired chart type from the drop-down menu.



Working with charts (5)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the “Add Chart Element” command on the

“Design Tab”, then choose the desired element from the drop-down menu.



Working with charts (6)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the “Add Chart Element” command on the

“Design Tab”, then choose the desired element from the drop-down menu.



Working with charts (7)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the “Add Chart Element” command on the

“Design Tab”, then choose the desired element from the drop-down menu.



Working with charts (8)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the “Add Chart Element” command on the

“Design Tab”, then choose the desired element from the drop-down menu.



Working with charts (9)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the “Add Chart Element” command on the

“Design Tab”, then choose the desired element from the drop-down menu.



Excel also includes several different chart styles, which allow you to quickly

modify the look and feel of your chart.

To change the chart style, select the desired style from the “Chart Styles”

group.

Working with charts (10)



You can also use the chart formatting shortcut buttons to quickly: (1) add 

chart elements, (2) change the chart style, and (3) filter the chart data.

1

2

3

1

Working with charts (11)



2

You can also use the chart formatting shortcut buttons to quickly: (1) add 

chart elements, (2) change the chart style, and (3) filter the chart data.

1

2

3

Working with charts (12)



3

You can also use the chart formatting shortcut buttons to quickly: (1) add 

chart elements, (2) change the chart style, and (3) filter the chart data.

1

2

3

Working with charts (13)



It's easy to switch to a new chart type.

Click the “Change Chart Type” command on the “Design Tab”, then choose

the desired chart from the drop-down menu.

Working with charts (14)



Formulas & Functions

One of the most powerful features in Excel is the ability to calculate

numerical information using formulas.

Formulas are equations that perform calculations in your spreadsheet.

Formulas always begin with an equals sign (=).

Functions are Excel-defined formulas - They take data you select and enter,

perform calculations on them, and return value(s).

All functions have a common format - the equals sign followed by the

function name followed by the input in parentheses.

Formulas

1

2

3

4

1

2

3

4

Functions



Formulas (1)

Excel uses standard operators for formulas, such as a plus sign for addition

(+), a minus sign for subtraction (-), an asterisk for multiplication (*), a

forward slash for division (/), and a caret (^) for exponents.

All formulas in Excel must begin with an equals sign (=).

Most of the time you will use cell addresses to create a formula.

By combining a mathematical operator with cell addresses, we can create a

variety of simple formulas in Excel.



We select the cell 

within the result 

will be displayed 

and then we type 

the equation using 

cell addresses & 

operators

We type the 

numbers in the 

cells we used for 

forming the 

equation - The 

result depends on 

the used numbers

Formulas (2)



If the result of a formula is too large to be displayed in a cell, it may appear as

pound signs (#######) instead of a value - In this case, we simply increase

the column width.

The true advantage of using cell addresses is that it allows us to update data

in our worksheet without having to rewrite formulas.

Rather than typing cell addresses, we can point & click on the desired cells.

Formulas can also be copied to adjacent cells with the fill handle.

Select the cell 

(D3) that will 

contain the 

formula

Formulas (3)



If the result of a formula is too large to be displayed in a cell, it may appear as

pound signs (#######) instead of a value - In this case, we simply increase

the column width.

The true advantage of using cell addresses is that it allows us to update data

in our worksheet without having to rewrite formulas.

Rather than typing cell addresses, we can point & click on the desired cells.

Formulas can also be copied to adjacent cells with the fill handle.

Select the cell 

(B3) you wish to 

reference first in 

the formula

Formulas (4)



If the result of a formula is too large to be displayed in a cell, it may appear as

pound signs (#######) instead of a value - In this case, we simply increase

the column width.

The true advantage of using cell addresses is that it allows us to update data

in our worksheet without having to rewrite formulas.

Rather than typing cell addresses, we can point & click on the desired cells.

Formulas can also be copied to adjacent cells with the fill handle.

Type the 

mathematical 

operator you 

wish to use -

Select the cell 

(C3) you wish to 

reference 

second in the 

formula

Formulas (5)



If the result of a formula is too large to be displayed in a cell, it may appear as

pound signs (#######) instead of a value - In this case, we simply increase

the column width.

The true advantage of using cell addresses is that it allows us to update data

in our worksheet without having to rewrite formulas.

Rather than typing cell addresses, we can point & click on the desired cells.

Formulas can also be copied to adjacent cells with the fill handle.

Press Enter -

The formula will 

be calculated, 

and the value 

will be displayed 

in the cell

Formulas (6)



Formulas (7)

In order to use Excel to calculate complex formulas, you will need to

understand the order of operations.

Parentheses are the best way to define which calculations will be performed

first in Excel.



Formulas (8)

There may be times when you do not want a cell reference to change when

filling cells (called as absolute reference).

An absolute reference is designated by the addition of a dollar sign ($).

You will generally use the $A$2 format when creating formulas that contain

absolute references - The other two formats are used much less frequently.



Formulas (9)



Functions (1)

A function is a predefined formula that performs calculations using specific

values in a particular order.

Excel includes many common functions that can be useful for quickly finding

the sum, average, count, maximum value, for a range of cells.

In order to work correctly, a function must be written a specific way, which is

called the syntax.

The basic syntax for a function is an equals sign (=), the function name

(SUM, for example), and one or more arguments (arguments contain the

information you want to calculate).

Arguments can refer to both individual cells and cell ranges and must be

enclosed within parentheses.

This function would calculate 

the sum of the values in the 

cell range A1:A20 - The 

function contains only one 

argument



Functions (2)

Multiple arguments must be separated by a comma. The function 

=SUM(A1:A3, C1:C2, E2) will add the values of all the cells in the three 

arguments



Functions (3)

Excel has a variety of functions available. Here are some of the most

common functions you'll use:

 SUM: This function adds all of the values of the cells in the argument.

 AVERAGE: This function determines the average of the values included in the

argument. It calculates the sum of the cells and then divides that value by the

number of cells in the argument.

 MEDIAN: This function determines the median of the values included in the

argument, i.e. the value separating the higher half from the lower half of a

data sample.

 COUNT: This function counts the number of cells with numerical data in the

argument.

 MAX/MIN: This function determines the highest/lowest cell value included in

the argument.

 UPPER: This function is used in cases where you need to convert text to

uppercase.



Functions (4)

The “AutoSum command” in “Home Tab” allows you to automatically insert

the most common functions into your formula, including SUM, AVERAGE,

COUNT, MIN, and MAX.



Functions (5)

You can search for functions by category, such as Financial, Logical, Text,

Date & Time, and more from the Function Library on the “Formulas Tab”.

If you're having trouble finding the right function, the “Insert Function”

command allows you to search for functions using keywords.



Exercise No1

Use “Fill Handle” to fill column B (shops).

Format titles in cells B2 & C2 (Bold, Bottom Border, Center).

Format number in column C (Comma format, Decimal places = 0).

Sort data in column C from the smallest number to the biggest.

Create a “Column Chart”.



Exercise No2

Format titles in cells C3:F3 (Bold, Center).

Format numbers in cells C4:F6 (Center, Red).

Format the main title (Merge & Center, Bold, Bottom Border).

Find the total sells for each shop and the grand total sells for all shops.

Create a “Bar Chart” with the total sells of each shop.



Exercise No3

Format titles in cells B2:F2 (Bold, Center).

Format numbers in column C & E (Accounting).

Fill in Column F using the following equation (column C*column D - column E).

Find the grand total value for all items.



Exercise No4

Resize all the columns by making their width equal to 9.

Use “Fill Handle” to fill column A (wells).

Format the main title (Merge & Center, Bold, Change font size).

Format titles in cells B2:K2 (Bold, Center, Italics).

Find the sum of cations and the sum of anions for every well.

Find the average of Na, Cl and EC of all wells.

Create a scatterplot of Cl-EC.



“Developing Excel skills is a powerful way to

start analyzing data like the professionals do”


